CVE-2025-4318Disclosure

LOWCVSS 9.0 · CRITICAL

Signal is active with 2 mentions in latest observed window

Immediate actions

  • Patch affected systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

The AWS Amplify Studio UI component property expressions in the aws-amplify/amplify-codegen-ui package lack input validation. This could potentially allow an authenticated user who has access to create or modify components to run arbitrary JavaScript code during the component rendering and build process.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-95

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Threat summary

  • Patch or workaround signal is available
  • 2 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 2 signals
  • Disclosure: 1 classified signal
  • 2 total mentions across 1 day

Deep dive

Activity timeline2 mentions / 1d
01122Mentions · 2026-07-31: 2Patch / Workaround · 2026-07-31: 1Technical Details · 2026-07-31: 207-31
Signal classification2 categories
Disclosure
150.0%
Patch
150.0%
Referenced assets1 URL
Full discourse2 posts
  • DailyCVE@dailycve
    Disclosure

    🔴 #AWS Amplify Studio, Code Injection, #CVE-2025-4318 (Critical) -DC-Jul2026-1117 https://dailycve.com/aws-amplify-studio-code-injection-cve-2025-4318-critical-dc-jul2026-1117/

    Post summary

    The tweet announces a new critical code injection vulnerability (CVE‑2025‑4318) in AWS Amplify Studio, without detailing exploits, patches, or confirmed active exploitation.

    0000154
    224 followersView on X
  • Upwind Security MDR@UpwindMDR
    Patch

    🚨Critical - AWS Amplify Studio Codegen UI Expression Injection RCE (CVE-2025-4318) aws-amplify/amplify-codegen-ui accepts unvalidated UI component property expressions; an authenticated user who can create/modify components can inject malicious expressions that execute arbitrary JavaScript during component rendering and in the build/codegen pipeline. Instances without Amplify Studio component editing permissions are not impacted. 👉Affected: aws-amplify/amplify-codegen-ui <= 2.20.2 (also @aws-amplify/codegen-ui-react) | Upgrade to 2.20.4

    Post summary

    The post reports the CVE‑2025‑4318 vulnerability in Amplify Studio and recommends upgrading to version 2.20.4 to mitigate.

    0000083
    275 followersView on X

Explore more