CVE-2026-112362

LOWCVSS 9.1 · CRITICAL

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Track advisory updates for patch or workaround availability

Recommended action window: Monitor and triage in normal cycle

NVD description

@fastify/express is a Fastify plugin that runs Express middleware inside Fastify. In versions 4.0.5 through 4.0.8, when Fastify runs with the non-default ignoreDuplicateSlashes option enabled, the plugin matches path-scoped Express middleware against a URL whose duplicate-slash normalization has also collapsed the separator after an absolute-form request target's scheme, so Fastify's router resolves the request to the scoped path and runs the handler while the Express layer no longer sees that path. As a result, a request using an absolute-form target can reach a handler on a scoped route such as an admin path while the middleware for authentication, authorization, or rate limiting is skipped. An unauthenticated attacker needs only the non-default ignoreDuplicateSlashes option to be enabled. The issue is fixed in @fastify/express 4.0.9, and users should upgrade to 4.0.9 or later. As a workaround, enforce authentication in a Fastify hook such as preHandler that runs after the router resolves the request, or leave ignoreDuplicateSlashes at its default.

0.0/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-436

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

NONE

Momentum

STABLE

Threat summary

  • 3 mentions across 2 observed days
  • Momentum state: stable

What's happening

  • Peaked 1d ago at 2 mentions (2026-10-27); latest day: 1
  • 3 total mentions across 2 days

Deep dive

Activity timeline3 mentions / 2d
01122Mentions · 2026-10-27: 2Mentions · 2026-10-28: 110-2710-28
Referenced assets1 URL
Full discourse3 posts
  • Ulises Gascón@kom_256

    🚨 Critical-severity security fix in @fastify/express@4.0.9 just released! Patches CVE-2026-112362: @fastify/express vulnerable to path-scoped middleware bypass via absolute-form request targets https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746

    01031181
    5.5K followersView on X
  • Parameter Watch@ParameterWatch

    ⚠️ CVE-2026-112362 (9.1) ⚠️ The fastify/express plugin runs Express middleware inside Fastify and lets an unauthenticated attacker reach routes that should need a login. Versions 4.0.5 up to (but not including) 4.0.9 are affected. Upgrade to 4.0.9 or later. https://t.co/x5erqfVDXd

    1001046
    21 followersView on X
  • Eliran Emuna@EmunaEliran

    🚨 Fastify auth bypass (CVE-2026-112362), CVSS 3.1 9.1 (CNA) 🔓 fastify-express: absolute-form requests hit /admin-style routes, skipping auth middleware ⚠️ Needs non-default ignoreDuplicateSlashes ✅ Fixed: 4.0.9 (4.0.5-4.0.8 affected) 🔗 https://github.com/fastify/fastify-express/security/advisories/GHSA-6h42-57hq-9746 #AppSec #NodeJS https://t.co/R9OTTwXrJS

    0000035
    76 followersView on X

Explore more