CVE-2026-16635Patch

LOWCVSS 8.8 · HIGH

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch affected systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

The Pronamic Pay plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 10.1.0 This is due to the `maybe_update_user_role()` function passing an attacker-controlled Gravity Forms field value (`$lead[$feed->user_role_field_id]`) directly into `WP_User::set_role()` without any allowlist validation, capability comparison, or permission check to constrain which roles can be assigned. This makes it possible for authenticated attackers, with Subscriber-level access and above, to escalate their own WordPress account to Administrator by tampering with the role field value in a form submission. Exploitation requires that an administrator has already configured a Pronamic Pay payment feed in Gravity Forms with the **Update User Role** option enabled and mapped to a form field; once that configuration is in place, no further preconditions exist to prevent an authenticated attacker from exploiting this vulnerability.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-269

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

STABLE

Threat summary

  • Patch or workaround signal is available
  • 2 mentions across 2 observed days
  • Momentum state: stable

What's happening

  • Patch or workaround mentioned in 2 signals
  • Technical details provided in 2 signals
  • Peaked 1d ago at 1 mentions (2026-08-01); latest day: 1
  • 2 total mentions across 2 days

Deep dive

Activity timeline2 mentions / 2d
00111Mentions · 2026-08-01: 1Mentions · 2026-08-02: 1Patch / Workaround · 2026-08-01: 1Patch / Workaround · 2026-08-02: 1Technical Details · 2026-08-01: 1Technical Details · 2026-08-02: 108-0108-02
Signal classification1 categories
Patch
2100.0%
Referenced assets1 URL
By indicator
Full discourse2 posts
  • Hugo | DevOps | Cybersecurity 🇱🇻@HugoValters
    Patch

    CVE-2026-16635 - Privilege Escalation in Pronamic Pay WordPress plugin. Auth Subscriber+ can set any role via Gravity Forms. CVSS 8.8. Unpatched - disable or restrict until fix. #CVE #WordPress #infosec #developer #developers #100daysofcode #100daysofcodechallange #git #github #gitlab #redteam #blueteam https://www.valtersit.com/cve/CVE-2026-16635/

    Post summary

    The post highlights an unpatched privilege‑escalation flaw in the Pronamic Pay WordPress plugin, noting a workaround of disabling or restricting the plugin until a fix is released.

    0000057
    979 followersView on X
  • ADK Cyber@ADKCyber
    Patch

    CVE-2026-16635 (CVSS 8.8): Pronamic Pay WordPress plugin vulnerable to privilege escalation in versions <=10.1.0. Update immediately if deployed. via NVD Recent High CVSS #CyberSecurity #InfoSec #Vulnerability https://t.co/Pq5qil68vu

    Post summary

    Pronamic Pay WordPress plugin is susceptible to privilege escalation (CVE‑2026‑16635, CVSS 8.8). Users should apply the available patch or update the plugin to version 10.1.1 or newer immediately.

    0000047
    90 followersView on X

Explore more