CVE-2026-32804Patch(dell / powerflex_manager)

LOWCVSS 8.1 · HIGH

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch dell powerflex_manager systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

Dell PowerFlex Manager, version(s) prior to 5.1.0.1, contain(s) an Improper Authentication vulnerability. An unauthenticated attacker with adjacent network access could potentially exploit this vulnerability, leading to Unauthorized access.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-287

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • powerflex_manager

Threat summary

  • Patch or workaround signal is available
  • 1 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 1 signal
  • 1 total mentions across 1 day

Affected systems

Vendors
Products
powerflex_manager

Deep dive

Activity timeline1 mentions / 1d
00111Mentions · 2026-06-17: 1Patch / Workaround · 2026-06-17: 1Technical Details · 2026-06-17: 106-17
Signal classification1 categories
Patch
1100.0%
Full discourse1 post
  • Upwind Security MDR@UpwindMDR
    Patch

    🚨High - Dell PowerFlex Manager Improper Authentication Unauthorized Access (CVE-2026-32804) Dell PowerFlex Manager contains an Improper Authentication vulnerability (CWE-287) that allows an unauthenticated attacker on the adjacent network to bypass authentication entirely - no credentials, no user interaction required. Successful exploitation gives the attacker high-impact write access to the system and can cause denial of service. The attack vector is adjacent network (AV:A), meaning the attacker must be on the same network segment or VLAN - reducing but not eliminating real-world risk in enterprise environments where PowerFlex is commonly deployed. 👉Upgrade to PowerFlex Software 5.1.0.1 or later (4.x branch: 4.5.5.2 or later).

    Post summary

    A newly disclosed authentication flaw in Dell PowerFlex Manager (CVE-2026-32804) allows unauthenticated attackers on the same network to gain full write access and cause service disruption, and Dell recommends upgrading to specified software versions to mitigate the risk.

    0000062
    217 followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appdellpowerflex_manager---

Explore more