CVE-2026-41252Patch(neutrinolabs / xrdp)

LOWCVSS 9.8 · CRITICAL

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch neutrinolabs xrdp systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

xrdp is an open source RDP server. Versions 0.10.6 and prior contain a missing bounds check in xrdp, which allows a heap-based buffer overflow when operating in vnc-any mode. The issue occurs during the handling of RFB protocol color map messages from a VNC server, where incoming color indices are not properly validated. A malicious VNC server can exploit this flaw by sending crafted messages with out-of-range values, leading to an out-of-bounds write on the heap. This memory corruption can result in a denial of service (DoS) or potentially allow remote code execution (RCE) prior to authentication. This issue has been fixed in version 0.10.6.1.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-122

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • xrdp

Threat summary

  • Patch or workaround signal is available
  • 1 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 1 signal
  • 1 total mentions across 1 day

Affected systems

Products
xrdp

Deep dive

Activity timeline1 mentions / 1d
00111Mentions · 2026-07-28: 1Patch / Workaround · 2026-07-28: 1Technical Details · 2026-07-28: 107-28
Signal classification1 categories
Patch
1100.0%
Referenced assets1 URL
By indicator
Full discourse1 post
  • Wazuh@wazuh
    Patch

    xrdp is affected by CVE-2026-41252 (CVSS 9.8 - Critical), a heap-based buffer overflow in vnc-any mode that can cause DoS or potential pre-auth RCE. Upgrade to 0.10.6.1 or later. Read more: https://ow.ly/gtSo50ZtxR7 #Vulnerability #Cybersecurity https://t.co/M1kXzuYfOQ

    Post summary

    The tweet announces that xrdp is vulnerable to CVE‑2026‑41252, a critical heap‑based buffer overflow, and advises users to upgrade to version 0.10.6.1 or later.

    080100792
    8.2K followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appneutrinolabsxrdp---

Explore more