CVE-2026-41871Patch(apache / nutch)

LOWCVSS 9.8 · CRITICAL

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch apache nutch systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

Missing Authorization, Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Nutch Server (Nutch REST API). This issue affects Apache Nutch: from 1.10 through 1.22. Users are recommended to upgrade to version 1.23, which removes the Nutch Server. If an upgrade is not possible, user must restrict access to instances running the Nutch Service to trusted users only. Please, also visit the Apache Nutch security advisories https://nutch.apache.org/documentation/security/ .

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-470CWE-862

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • nutch

Threat summary

  • Patch or workaround signal is available
  • 1 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 1 signal
  • 1 total mentions across 1 day

Affected systems

Vendors
Products
nutch

Deep dive

Activity timeline1 mentions / 1d
00111Mentions · 2026-09-12: 1Patch / Workaround · 2026-09-12: 1Technical Details · 2026-09-12: 109-12
Signal classification1 categories
Patch
1100.0%
Referenced assets1 URL
By indicator
Full discourse1 post
  • SecAlerts@SecAlertsCo
    Patch

    🪲 Apache Nutch REST API exposes unauthenticated reflection-based job execution. CVE-2026-41871 scores 9.8 — no auth, no interaction, full RCE risk. Patch now if Nutch Server is exposed. #cybersecurity #ciso #vulnerabilities #mssp #Apache https://secalerts.co/vulnerability/CVE-2026-41871?utm_campaign=x https://t.co/9BOpZJfdT3

    Post summary

    Apache Nutch REST API has a critical unauthenticated RCE vulnerability (CVE-2026-41871). A patch should be applied immediately if the server is exposed.

    00000144
    890 followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appapachenutch---

Explore more