CVE-2026-59898Disclosure(netty / netty)

LOWCVSS 7.5 · HIGH

Signal is active with 2 mentions in latest observed window

Immediate actions

  • Track advisory updates for patch or workaround availability

Recommended action window: Monitor and triage in normal cycle

NVD description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, ab attacker can force WebSocket upgrade via the lax V07 (or V08) handshaker by sending `Sec-WebSocket-Version: 7` and omitting `Connection: Upgrade` / `Upgrade: websocket` headers, completing a protocol switch that a proxy would not recognize as an Upgrade request and enabling HTTP request smuggling / protocol-confusion attacks. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

0.0/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-444

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

NONE

Momentum

NONE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • netty

Threat summary

  • 2 mentions across 1 observed day

What's happening

  • Technical details provided in 1 signal
  • Disclosure: 2 classified signals
  • 2 total mentions across 1 day

Affected systems

Vendors
Products
netty

Deep dive

Activity timeline2 mentions / 1d
01122Mentions · 2026-07-29: 2Technical Details · 2026-07-29: 107-29
Signal classification1 categories
Disclosure
2100.0%
Referenced assets4 URLs
Full discourse2 posts
  • CVE@CVEnew
    Disclosure

    CVE-2026-59898 Netty is an asynchronous, event-driven network application framework. Prior to versions http://4.1.136.Final and http://4.2.16.Final, ab attacker can force WebSocket upgrade via t… https://www.cve.org/CVERecord?id=CVE-2026-59898

    Post summary

    The text announces a CVE that allows forced WebSocket upgrades in Netty versions below 4.1.136.Final and 4.2.16.Final, providing vulnerability details but lacking PoC, exploitation, or patch information.

    00001504
    57.9K followersView on X
  • Infoflowcloud@infoflowcloud
    Disclosure

    🚨*CVE* CVE-2026-59898 Netty is an asynchronous, event-driven network application framework. Prior to versions http://4.1.136.Final and http://4.2.16.Final, ab attacker can force WebSocket upgrade via t… https://www.cve.org/CVERecord?id=CVE-2026-59898 ----- Traducció… http://infoflow.cloud`

    Post summary

    A new Netty vulnerability (CVE‑2026‑59898) that allows attackers to force a WebSocket upgrade in pre‑4.1.136 and 4.2.16 is noted, but no PoC, exploit code, active exploitation, patch, or technical depth is included.

    0000031
    96 followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appnettynetty---

Explore more