
OpenSearch CVE-2026-63393 (CVSS 8.7) affects SQL in 2.x (2.8.0-2.19.6) and pre-3.7.0. Remote authenticated users impacted. Review and update instances. via NVD Recent High CVSS #CyberSecurity #InfoSec #Vulnerability https://t.co/Z4jLWg4FFg
Signal is active with 1 mentions in latest observed window
Recommended action window: Monitor and triage in normal cycle
NVD description
OpenSearch SQL supports querying OpenSearch data using SQL and Piped Processing Language. In the 2.x line from 2.8.0.0 until 2.19.6.0, and the 3.x line prior to 3.7.0.0, a remote authenticated user with basic read/search permissions can provide a crafted `cursor` parameter to the `plugins/sql` endpoint and trigger unsafe deserialization of untrusted data, resulting in arbitrary code execution on the server. This issue is fixed in repository releases 2.19.6.0 and 3.7.0.0.
Priority
LOW
Exploitation
NONE
PoC
NONE
Patch
NONE
Momentum
NONE

OpenSearch CVE-2026-63393 (CVSS 8.7) affects SQL in 2.x (2.8.0-2.19.6) and pre-3.7.0. Remote authenticated users impacted. Review and update instances. via NVD Recent High CVSS #CyberSecurity #InfoSec #Vulnerability https://t.co/Z4jLWg4FFg