CVE-2026-87776Patch

LOWCVSS 7.5 · HIGH

Exploit discussion active in current signal (2 latest mentions)

Immediate actions

  • Patch affected systems immediately
  • Hunt for exploitation attempts and persistence artifacts
  • Increase monitoring for publicly documented tradecraft

Recommended action window: High priority (within 72h)

NVD description

compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.

2.0/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-401CWE-459

Priority

LOW

Exploitation

NONE

PoC

YES

Patch

AVAILABLE

Momentum

NONE

Threat summary

  • Public PoC is present in monitored signal
  • Patch or workaround signal is available
  • 2 mentions across 1 observed day

What's happening

  • PoC mentioned or linked in 1 signal
  • Patch or workaround mentioned in 2 signals
  • Technical details provided in 2 signals
  • 2 total mentions across 1 day

Deep dive

Activity timeline2 mentions / 1d
01122Mentions · 2026-09-11: 2PoC Mentioned / Linked · 2026-09-11: 1Patch / Workaround · 2026-09-11: 2Technical Details · 2026-09-11: 209-11
Signal classification1 categories
Patch
2100.0%
Referenced assets2 URLs
Full discourse2 posts
  • HOL@HashgraphOnline
    Patch

    Anyone who can hit your Express app and hang up mid-response can leak zlib memory until the process dies. Upgrade compression to 1.8.2. CVE-2026-87776 https://hol.org/blog/cve-2026-87776-express-compression-zlib-abort-memory-dos https://t.co/5AATRznN54

    Post summary

    The post alerts users to a memory‑leak DoS vulnerability in Express.js compression that can be mitigated by upgrading to version 1.8.2.

    011701.2K
    19.1K followersView on X
  • Ulises Gascón@kom_256
    Patch

    🚨 High-severity security fix in compression@1.8.2 just released! Patches CVE-2026-87776: compression vulnerable to Denial of Service via memory leak on premature response close https://github.com/expressjs/compression/security/advisories/GHSA-vc2v-76pw-4v95

    Post summary

    A new patch for [email protected] addresses a high‑severity DoS vulnerability (CVE‑2026‑87776) caused by a memory leak when prematurely closing a response.

    00020213
    5.5K followersView on X

Explore more