CVE-2026-88824Patch

LOWCVSS 8.8 · HIGH

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch affected systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

The Master Blocks WordPress plugin before 1.5.0 does not have authorisation on one of its REST routes, allowing unauthenticated users to update its settings, including a value that is output unescaped in the admin area, leading to Stored XSS that executes in the session of any administrator visiting a wp-admin page.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-79

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Threat summary

  • Patch or workaround signal is available
  • 1 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 1 signal
  • 1 total mentions across 1 day

Deep dive

Activity timeline1 mentions / 1d
00111Mentions · 2026-09-20: 1Patch / Workaround · 2026-09-20: 1Technical Details · 2026-09-20: 109-20
Signal classification1 categories
Patch
1100.0%
Referenced assets1 URL
By indicator
Full discourse1 post
  • ADK Cyber@ADKCyber
    Patch

    WordPress users: CVE-2026-88824 (CVSS 8.8) in Master Blocks plugin before 1.5.0 allows unauthenticated settings updates. Verify and update the plugin. https://nvd.nist.gov/vuln/detail/CVE-2026… via NVD Recent High CVSS #CyberSecurity #InfoSec #Vulnerability #AI #MachineLearning https://t.co/MiB1KkmWaQ

    Post summary

    The post discloses CVE-2026-88824 in the Master Blocks WordPress plugin (CVSS 8.8) and urges users to update to version 1.5.0 or later, linking to the NVD entry but providing no PoC or exploit code.

    0000043
    97 followersView on X

Explore more