CVE-2026-89064Disclosure

LOWCVSS 5.3 · MEDIUM

Signal is active with 2 mentions in latest observed window

Immediate actions

  • Patch affected systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

The All-in-One WP Migration and Backup plugin for WordPress is vulnerable to Insufficient Credential Protection in versions up to, and including, 7.110. This is due to the `Ai1wm_Main_Controller::init()` method — registered on the `admin_init` hook, which fires unauthenticated on `admin-ajax.php` and `admin-post.php` requests — reading `$_SERVER['PHP_AUTH_USER']` and `$_SERVER['PHP_AUTH_PW']` from any incoming request and writing them to the `ai1wm_auth_header` option via `update_option()` as a reversible base64-encoded string, with no capability check, nonce verification, `is_user_logged_in()` check, or confirmation that Basic authentication actually succeeded. This makes it possible for unauthenticated attackers to capture into the database, in reversible base64 form, any WordPress Application Password or HTTP Basic credential presented to `/wp-admin/` by a legitimate integration, or to overwrite the stored credential with an attacker-chosen value by sending an anonymous request carrying a crafted `Authorization: Basic` header. This is particularly impactful in environments using WordPress Application Passwords for REST API or third-party integrations, as those credentials are transmitted as HTTP Basic auth to `/wp-admin/` and will be silently harvested via this unauthenticated write path.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-522

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

NONE

Threat summary

  • Patch or workaround signal is available
  • 2 mentions across 1 observed day

What's happening

  • Patch or workaround mentioned in 1 signal
  • Technical details provided in 2 signals
  • Disclosure: 1 classified signal
  • 2 total mentions across 1 day

Deep dive

Activity timeline2 mentions / 1d
01122Mentions · 2026-09-17: 2Patch / Workaround · 2026-09-17: 1Technical Details · 2026-09-17: 209-17
Signal classification2 categories
Disclosure
150.0%
Patch
150.0%
Referenced assets2 URLs
Full discourse2 posts
  • 株式会社mgn@mgn_jpn
    Patch

    🚨 All-in-One WP Migration and Backup に脆弱性(深刻度 中) 500万サイト以上が利用 / CVSS 5.3 修正版 7.111 が公開済み https://shindan.m-g-n.me/alerts/cve-2026-89064/

    Post summary

    A medium-severity vulnerability (CVSS 5.3) in All-in-One WP Migration and Backup is reported as patched in version 7.111, with technical details provided.

    072911.9K
    425 followersView on X
  • LoreleiWeb@LoreleiWeb
    Disclosure

    🆕👉 All-in-One WP Migration and Backup https://wpdeeply.com/all-in-one-wp-migration-7-110-basic-auth-credential-storage-cve-2026-89064/ #loreleiweb All-in-One WP Migration and Backup 7.110 and earlier is affected by CVE-2026-89064, an unauthenticated credential-handling flaw. The plugin’s admin_init handler can store credentials from an incoming … https://t.co/yWS72ko5iD

    Post summary

    The text announces CVE-2026-89064, an unauthenticated credential-handling flaw in the All-in-One WP Migration and Backup plugin, providing technical details about the vulnerability without mentioning remediation, exploits, or active exploitation.

    00000175
    85.8K followersView on X

Explore more