CVE-2026-92087Patch

LOWCVSS 8.1 · HIGH

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch affected systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

@fastify/auth is a Fastify plugin that composes multiple authentication and authorization strategies into a single route guard. In versions 5.0.0 through 5.1.0, when strategies are composed with the relation "or" option together with the run "all" option and one entry is a nested array acting as an AND group, the group is evaluated in an order-dependent way: an earlier failing check is silently dropped and the group's result becomes the outcome of its last check. As a result, a request that satisfies only the last member of an AND group, for example an attacker who holds a valid API key but is not an administrator, is authorized instead of rejected, and a related order-dependent bypass affects the mirror configuration where the top-level relation is "and" and a nested group uses "or". The issue is fixed in @fastify/auth 5.1.1, and users should upgrade to 5.1.1 or later. As a workaround, omit the run "all" option where it is not required, order each AND group so its stricter check is evaluated last, or replace nested AND groups with an explicit top-level "and" composition.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-285CWE-697

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

STABLE

Threat summary

  • Patch or workaround signal is available
  • 2 mentions across 2 observed days
  • Momentum state: stable

What's happening

  • Patch or workaround mentioned in 2 signals
  • Technical details provided in 2 signals
  • Peaked 1d ago at 1 mentions (2026-09-16); latest day: 1
  • 2 total mentions across 2 days

Deep dive

Activity timeline2 mentions / 2d
00111Mentions · 2026-09-16: 1Mentions · 2026-09-30: 1Patch / Workaround · 2026-09-16: 1Patch / Workaround · 2026-09-30: 1Technical Details · 2026-09-16: 1Technical Details · 2026-09-30: 109-1609-30
Signal classification1 categories
Patch
2100.0%
Referenced assets1 URL
By indicator
Full discourse2 posts
  • DFIR Lab@DFIR_Lab
    Patch

    🚨 HIGH severity CVE-2026-92087 (CVSS 8.1) affects @fastify/auth plugin v5.0.0-5.1.0. Logic flaw in auth strategy composition allows authorization bypass. Attackers with valid API keys can bypass admin checks. Patch to v5.1.1+ immediately. #CVE #PatchNow https://t.co/xt0tW9t2v8

    Post summary

    The tweet reports a high-severity authorization bypass vulnerability in Fastify auth plugin and urges upgrading to version 5.1.1 or later.

    0000039
    143 followersView on X
  • Ulises Gascón@kom_256
    Patch

    🚨 High-severity security fix in @fastify/auth@5.1.1 just released! Patches CVE-2026-92087: @fastify/auth vulnerable to Authorization Bypass via order-dependent evaluation of composed auth https://github.com/fastify/fastify-auth/security/advisories/GHSA-7h52-2rwr-m76r

    Post summary

    The tweet announces the release of a patch for CVE-2026-92087, an authorization bypass vulnerability in @fastify/auth, and provides a link to the GitHub security advisory.

    00000207
    5.5K followersView on X

Explore more