CVE-2026-94054Patch(exim / exim)

LOWCVSS 5.3 · MEDIUM

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch exim exim systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, has an out-of-bounds write.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-787

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

STABLE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • exim

Threat summary

  • Patch or workaround signal is available
  • 6 mentions across 5 observed days
  • Momentum state: stable

What's happening

  • Patch or workaround mentioned in 5 signals
  • Technical details provided in 5 signals
  • Disclosure: 1 classified signal
  • Peaked 2d ago at 2 mentions (2026-09-21); latest day: 1
  • 6 total mentions across 5 days

Affected systems

Vendors
Products
exim

Deep dive

Activity timeline6 mentions / 5d
01122Mentions · 2026-09-19: 1Mentions · 2026-09-20: 1Mentions · 2026-09-21: 2Mentions · 2026-09-22: 1Mentions · 2026-10-27: 1Patch / Workaround · 2026-09-20: 1Patch / Workaround · 2026-09-21: 2Patch / Workaround · 2026-09-22: 1Patch / Workaround · 2026-10-27: 1Technical Details · 2026-09-20: 1Technical Details · 2026-09-21: 2Technical Details · 2026-09-22: 1Technical Details · 2026-10-27: 109-1909-2009-2109-2210-27
Signal classification2 categories
Patch
583.3%
Disclosure
116.7%
Referenced assets5 URLs
Classification over time
DateTotalLabels
2026-09-191
Disclosure1
2026-09-201
Patch1
2026-09-212
Patch2
2026-09-221
Patch1
2026-10-271
Patch1
Full discourse6 posts
  • ThreatWire@ThreatWire_
    Patch

    🚨 SECURITY UPDATE: Exim 4.100.1 fixes multiple serious security issues affecting the mail server. CVE-2026-94054 is an out-of-bounds write in Proxy Protocol v1 parsing that can lead to heap corruption. The release also fixes a GnuTLS use-after-free, a Proxy Protocol data-leak issue, and additional SMTP smuggling attack variants. ⚠️ Exim versions up to 4.100 are affected. 🔴 Update to Exim 4.100.1. 🔗 https://www.openwall.com/lists/oss-security/2026/09/19/2 #Exim #CVE #EmailSecurity #CyberSecurity #Infosec

    Post summary

    The text is a security update announcement informing users that Exim version 4.100.1 has been released to patch multiple serious vulnerabilities, including CVE-2026-94054, and advises users to immediately update to the latest version.

    05090957
    1.9K followersView on X
  • Daily CyberSecurity@Daily_CyberSec
    Patch

    Exim 4.100.1 patches a serious Exim vulnerability set: Proxy Protocol heap flaws, a GnuTLS use-after-free, and SMTP smuggling (CVE-2026-94054). Upgrade now. #Exim #EximVulnerability #SMTPsmuggling #ProxyProtocol #MailServerSecurity #CVE202694054 https://securityonline.info/exim-4-100-1-vulnerabilities/

    Post summary

    The text announces patches for Exim vulnerabilities (including CVE-2026-94054) in version 4.100.1 and urges users to upgrade, providing technical details and a security advisory link.

    01021579
    13.0K followersView on X
  • VulDB 🛡@vuldb
    Disclosure

    A new vulnerability with increased severity was disclosed for Exim (CVE-2026-94054) https://vuldb.com/vuln/407982

    Post summary

    The text is a brief disclosure announcement of a new Exim vulnerability (CVE-2026-94054) with a link to vuldb.com; no PoC, exploit, patch, or technical details are included in the text itself.

    00020225
    2.3K followersView on X
  • CVE@CVEnew
    Patch

    CVE-2026-94054 Exim before 4.100.1, when Proxy-Protocol is used with an attacker-controlled proxy, has an out-of-bounds write. https://www.cve.org/CVERecord?id=CVE-2026-94054

    Post summary

    The tweet discloses CVE-2026-94054, an out-of-bounds write in Exim versions prior to 4.100.1 when Proxy-Protocol is used with an attacker-controlled proxy, and notes that version 4.100.1 fixes the issue.

    000101.7K
    58.1K followersView on X
  • Hugo | DevOps | Cybersecurity@HugoValters
    Patch

    CVE-2026-94054: Exim before 4.100.1 has an out-of-bounds write via attacker-controlled Proxy-Protocol, CVSS 7. No patch yet, so restrict proxy exposure now. #CVE #infosec #Exim https://www.valtersit.com/cve/CVE-2026-94054/ #Exim #CVEALERT #CVE #infosec #Linux #XSS #valtersit #snippet #SysAdmin #cybersecurity #devsecops #devops #developer #100daysofcode #git #github #gitlab #redteam #blueteam #ethicalhacker #cybersecurityawareness #cybersecuritynews #cybersecuritytips #python #hacker #kali #ubuntu #debian #docker

    Post summary

    The tweet announces CVE-2026-94054 in Exim (out-of-bounds write, CVSS 7), confirms no patch is available, and provides a workaround (restricting proxy exposure).

    0000049
    1.1K followersView on X
  • Rıdvan Yağlı@ridvanyagli
    Patch

    🚨 Exim'de 4 güvenlik açığının da yamalandığı 4.100.1 sürümü yayınlandı. • CVE-2026-94054 — Proxy Protocol v1 OOB Write / Heap Corruption — High • CVE-2026-94055 — GnuTLS Use-after-Free — Low • CVE-2026-94056 — Proxy Protocol v2 Stack Memory Leak — High • CVE-2026-94057 — SMTP Smuggling — Medium Mutlaka 4.100.1 sürümüne güncelleme yapın.

    Post summary

    The advisory announces that Exim version 4.100.1 patches four CVEs (CVE‑2026‑94054 through CVE‑2026‑94057) and urges immediate upgrade to the fixed release.

    00000324
    2.4K followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appeximexim---

Explore more