CVE-2026-94055Patch(exim / exim)

LOWCVSS 5.3 · MEDIUM

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Patch exim exim systems immediately

Recommended action window: Monitor and triage in normal cycle

NVD description

Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free.

0.5/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-416

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

AVAILABLE

Momentum

STABLE

Are you affected?

If you run products in this scope, you should treat this CVE as relevant to your environment.

  • exim

Threat summary

  • Patch or workaround signal is available
  • 4 mentions across 3 observed days
  • Momentum state: stable

What's happening

  • Patch or workaround mentioned in 3 signals
  • Technical details provided in 4 signals
  • Disclosure: 1 classified signal
  • Peaked 1d ago at 2 mentions (2026-09-22); latest day: 1
  • 4 total mentions across 3 days

Affected systems

Vendors
Products
exim

Deep dive

Activity timeline4 mentions / 3d
01122Mentions · 2026-09-20: 1Mentions · 2026-09-22: 2Mentions · 2026-10-29: 1Patch / Workaround · 2026-09-22: 2Patch / Workaround · 2026-10-29: 1Technical Details · 2026-09-20: 1Technical Details · 2026-09-22: 2Technical Details · 2026-10-29: 109-2009-2210-29
Signal classification2 categories
Patch
375.0%
Disclosure
125.0%
Referenced assets3 URLs
Classification over time
DateTotalLabels
2026-09-201
Disclosure1
2026-09-222
Patch2
2026-10-291
Patch1
Full discourse4 posts
  • CVE@CVEnew
    Disclosure

    CVE-2026-94055 Exim before 4.100.1, when certain non-default TLS settings are used with GnuTLS, has a use-after-free. https://www.cve.org/CVERecord?id=CVE-2026-94055

    Post summary

    The text announces CVE-2026-94055, a use-after-free vulnerability in Exim before version 4.100.1 when certain non-default TLS settings are used with GnuTLS, and includes a link to the CVE record.

    000101.1K
    58.1K followersView on X
  • Hugo | DevOps | Cybersecurity@HugoValters
    Patch

    CVE-2026-94055: use-after-free in Exim before 4.100.1 with non-default GnuTLS TLS settings. CVSS 3.7. Low severity, patch still under review, so track it and upgrade when 4.100.1 lands. #CVE #infosec #Exim https://www.valtersit.com/cve/CVE-2026-94055/ #Exim #CVEALERT #CVE #infosec #Linux #XSS #valtersit #snippet #SysAdmin #cybersecurity #devsecops #devops #developer #100daysofcode #git #github #gitlab #redteam #blueteam #ethicalhacker #cybersecurityawareness #cybersecuritynews #cybersecuritytips #python #hacker #kali #ubuntu #debian #docker

    Post summary

    The text discloses a use-after-free vulnerability in Exim versions before 4.100.1, reporting a low CVSS score. It explicitly recommends upgrading to 4.100.1 once the patch is available.

    0000049
    1.1K followersView on X
  • zoomeyebot@zoomeyebot
    Patch

    🚨 Exim 4.100.1 Patches Four Security Vulnerabilities, Including Two High-Severity Proxy Protocol Flaws Critical Vulnerability Alert! Exim is affected by CVE-2026-94055. 🔍 Identify Targets via ZoomEye: Search Dork: app="Exim" Exposure: 10.1m instances identified globally. ZoomEye Search Link: 👉 https://www.zoomeye.ai/searchResult?q=YXBwPSJFeGltIg%3D%3D #Exim #CVE #Vulnerability #MailServer #CyberSecurity

    Post summary

    The post primarily announces that Exim 4.100.1 patches multiple vulnerabilities, including high-severity proxy protocol flaws, and provides a ZoomEye search for exposed instances. It does not report PoC, exploit tooling, active exploitation, or debunking claims.

    0000041
    24 followersView on X
  • Rıdvan Yağlı@ridvanyagli
    Patch

    🚨 Exim'de 4 güvenlik açığının da yamalandığı 4.100.1 sürümü yayınlandı. • CVE-2026-94054 — Proxy Protocol v1 OOB Write / Heap Corruption — High • CVE-2026-94055 — GnuTLS Use-after-Free — Low • CVE-2026-94056 — Proxy Protocol v2 Stack Memory Leak — High • CVE-2026-94057 — SMTP Smuggling — Medium Mutlaka 4.100.1 sürümüne güncelleme yapın.

    Post summary

    The announcement reveals the release of Exim version 4.100.1, which addresses four security vulnerabilities (CVE-2026-94054 to CVE-2026-94057), and strongly advises administrators to upgrade immediately.

    00000324
    2.4K followersView on X
CPE platform detail1 entries

1 of 1 entries

PartVendorProductVersionTarget SWTarget HW
Appeximexim---

Explore more