CVE-2026-95860

LOWCVSS 9.1 · CRITICAL

Signal is active with 1 mentions in latest observed window

Immediate actions

  • Track advisory updates for patch or workaround availability

Recommended action window: Monitor and triage in normal cycle

NVD description

node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. SessionContext.getApplicableRolePermissions reads a missing or null DefaultRolePermissions metadata value instead of the configured namespace field, and the null result is treated permissively. An anonymous network client can consequently write variables with CurrentWrite access or call bound methods when an operator configured a restrictive namespace default and relied on inheritance. Servers with no declared policy, nodes with explicit per-node permissions, and correctly bound programmatic namespace metadata are outside the authorization-bypass case. This issue is fixed in version 2.180.0.

0.0/ 10 priority

Sources & remediation

Weakness type (CWE)
CWE-285CWE-636CWE-863CWE-1188

Priority

LOW

Exploitation

NONE

PoC

NONE

Patch

NONE

Momentum

NONE

Threat summary

  • 1 mentions across 1 observed day

What's happening

  • 1 total mentions across 1 day

Deep dive

Activity timeline1 mentions / 1d
00111Mentions · 2026-11-03: 111-03
Referenced assets1 URL
Full discourse1 post
  • cve.now@cvedotnow

    🆕 New CVE node-opcua (CVE-2026-95860) node-opcua, an OPC UA implementation for Node.js and TypeScript, is affected in versions from 2.42.0 up to (but not including) 2.180.0. Patch → 2.180.0 https://cve.now/CVE-2026-95860?utm_source=x&utm_medium=social&utm_campaign=cvedotnow&utm_content=critical

    010321.1K
    21.6K followersView on X

Explore more